Tuesday, August 3, 2010

Rygel 0.7.3 (Out of Their Minds)

Rygel 0.7.3 (Out of Their Minds) is out!

A new release in the current unstable 0.7.x series for upcoming GNOME 2.31.6
release.

- Add Album-art support.
- Add support for sorted Browse/Search.
- Don't push data after HTTP response is cancelled.
- Advertise support for search by "createClass".
- Revive accidently removed XBox hacks.
- Fix icon export for uninstalled case.
- Simplify plugin APIs to further abstract plugin developers from UPnP details.
- Add convenient MediaRenderer APIs for plugins. This involved moving most of
  the GstRenderer code to core.
- Fix seeking once again.
- Improve error handling in HTTP request handling code.
- Port to new DIDL-Lite contributor APIs.
- Port to Vala 0.9.3 and 0.9.4.
- Clean-up README and specify build and run-time dependencies.
- More debug output.
- MediaExport:
  - Make use of gupnp-dlna for faster, more complete and reliable metadata
    extraction.
  - Print a debug message if extraction fails for a file.
  - Add windows formats to positive list of file extensions to include in the
    metadata extraction.
  - Don't share anyt folder by default.
  - Fix url-escaped folder names on PS3.
  - Fix issue of empty title of top-level virtual folders on PS3.
  - Process 256 children at a time. This improves performance of harvesting of
    large folders.
- GstRenderer:
  - Rename to Playbin.
  - Advertize support for 'video/mp4'
  - Advertize support for RTSP
  - Handle error from playbin.
  - Don't claim support for unsupported UPnP actions and state variables.
- External:
  - Fix a crasher bug.
- Localization:
  - Add French translation.
  - Update Simplified Chinese translations.
  - Update German translation.
  - Update Galician translation.
  - Update Swedish translation.
  - Update Slovenian translation.
- Lots of other non-functional and/or minor improvements and fixes.

Dependency-related changes:

- Require Vala >= 0.9.3
- Require gupnp >= 0.13.4
- Require gupnp-av >= 0.5.8
- Require gupnp-dlna >= 0.2.1 (new dependency)
- Require libgee >= 0.5.2
- Use gtk+-2.0 (>= 2.21.5) if available rather than gtk+-3.0

Bugs fixed in this release:

607411 - Need to mention non-compile time deps.
624445 - Samsung can't FF/REW/PAUSE when playing video/avi from Rygel.
625556 - New configure flag to switch GTK+ version.

All contributors to this release:

Aron Xu 
Arun Raghavan 
Claude Paroz 
Eleanor Chen 
Frédéric Péters 
Javier Jardón 
Jens Georg 
Mario Blättermann 
Zeeshan Ali (Khattak) 

Download source tarball here

5 comments:

onlineG said...

When will there be a new release for the Nokia N900?

The FATAL repository hasn't been updated in a while :(
http://live.gnome.org/Rygel/N900

zeenix said...

The last stable release (0.6.0) was made available for N900 (which actually is much more newer than whats available in desktop distributions) and 0.8.0 is around the corner so you'll have new rygel soon enough on your n900.

zeenix said...

Oops, 0.6.0 was packaged but fatal never got to upload it. However, he is on it.

onlineG said...

Okay well I hope he can get some time to do it, because I think it's a really great app, it plays really well with my PS3, especially pictures and photos. Even some (lower bitrate) divx movies too! I'm especially interested in subtitle support. But anyways thanks for this cool app and keep up the good work!

Anonymous said...

hi,
I've tried to download de latest version of Rygel from de fatal repos but it still stuck in 0.4 version :(
regards